Any Lowrance Elite 5 or 7 Ti owners here?

Show us your Sounders and/or GPS Units in this section.
Post Reply
User avatar
KFDU Angler
Posts: 9
Joined: Sat Dec 17, 2016 5:36 am
Local Fishing Region: Port Phillip Bay
Kayaks: Dune PA14
Location: Werribee South

Any Lowrance Elite 5 or 7 Ti owners here?

#1 Post by chrisw » Tue May 23, 2017 3:01 pm

Anyone here own an Elite 5/7 Ti and who are also on firmware version 2.5 (latest)?

If so could you please try the following?

Create a new waypoint (or edit an existing one), tap the co-ordinates to display the edit dialog then attempt to alter any of the digits. See if it allows you to enter anything other than what is already there.

After closing that, long-press the waypoint button and select the 'find co-ordinate' option (I think it's called that; it should be the bottom-right button anyhow). It should pop up a dialog with a default location of all zeros. See if you can enter anything other than a 0 there.

If you can get this to work I'd like to know. It doesn't work for me and I've been going nuts trying to find out why - I cannot find any reference to it on the internet so had assumed it was a glitch on my unit. However I just got off the phone with Lowrance support in the US and the tech said the same thing happens to him when he tried it on a unit there, but that despite that he'd never heard of the issue!

Version 2.5 has been out for 4 months and if it truly does affect all 2.5 users then I'm gobsmacked that they don't know of it, as it renders it completely impossible to manually enter any GPS co-ordinates via the unit itself. Importing is still possible but that doesn't help you if you want to enter a point while on the water (which is what I was trying last Sunday, causing some rather colourful language and attempts to find what I was doing wrong reading the manual and using google on my tiny mobile phone display).

I'd be glad to be proved wrong on this as there doesn't appear to be any way to downgrade the firmware to something that works (previous version was 2.0; I would presume it does work though I never tried it as my unit is brand new).

Post Reply

Return to “Sounders And GPS Units”